Friday, April 8, 2011

An issue with Windows where mapping network drives at login is not working....

I enjoy first level support work (a.k.a. Help Desk or Service Desk). It is where I learned many of my soft-skills and advanced Windows troubleshooting skills. Many people, like me, who started out working in 1st level support usually stay in this role for a couple of years before moving into a higher level position. You tend to pick up a great deal of troubleshooting and networking knowledge while working on the help desk. I also have a great deal of respect for those who work in the help desk – it is not an easy job! But I must admit that sometimes, I get a little frustrated when one of the most common issues gets pushed up to the next level of support with absolutely zero troubleshooting done by the 1st level technician. Anyhoo, lets get started with the post…

There is an issue with Windows where network drives (which may also be called shared drives or network shared folders) assigned by Group Policy do not automatically map after a user logs into a computer that is joined to a domain. This issue occurs on all versions of Windows and it occurs at random. Why does this happen? Because Windows processes login settings regardless if Windows has initialized network connections or not. Let me explain….

There are many features of Windows that attempt to speed booting and speed up initializing the desktop after a user logs in. There is a great deal of processes that run in the background which affects network settings, services, and applications. Even if there is a current network connection, Windows re-initializes network connections before and after each login session. So, even if the network is unavailable for a moment Windows still tries to map the drive. If Windows can’t connect the drive, it simply stops trying to perform the task and never tells you about it. Make sense? Good.

Here is the fix: The user needs to log off of the computer, and log back in. That’s it.